Please login or register to participate.
Discussion
.
migrationuser Oct 14, 2009 03:19 PM
Hi,

Error we encountered on the Cynin Images Tab -

Request URL http://ip-address/cynin/root/app_images
Exception Type TraversalError
Exception Value ({}, 'main')
Traceback (innermost last):

Module ZPublisher.Publish, line 119, in publish
Module ZPublisher.mapply, line 88, in mapply
Module ZPublisher.Publish, line 42, in call_object
Module Shared.DC.Scripts.Bindings, line 313, in __call__
Module Shared.DC.Scripts.Bindings, line 350, in _bindAndExec
Module Products.CMFCore.FSPageTemplate, line 216, in _exec
Module Products.CacheSetup.patch_cmf, line 28, in FSPT_pt_render
Module Products.CacheSetup.patch_utils, line 9, in call_pattern
Module Products.CMFCore.FSPageTemplate, line 155, in pt_render
Module Products.CacheSetup.patch_cmf, line 74, in PT_pt_render
Module Products.CacheSetup.patch_utils, line 9, in call_pattern
Module Products.PageTemplates.PageTemplate, line 89, in pt_render
Module zope.pagetemplate.pagetemplate, line 117, in pt_render
Warning: Macro expansion failed
Warning: zope.traversing.interfaces.TraversalError: ({}, 'main')
Module zope.tal.talinterpreter, line 271, in __call__
Module zope.tal.talinterpreter, line 346, in interpret
Module zope.tal.talinterpreter, line 891, in do_useMacro
Module zope.tal.talinterpreter, line 346, in interpret
Module zope.tal.talinterpreter, line 536, in do_optTag_tal
Module zope.tal.talinterpreter, line 521, in do_optTag
Module zope.tal.talinterpreter, line 516, in no_tag
Module zope.tal.talinterpreter, line 346, in interpret
Module zope.tal.talinterpreter, line 957, in do_defineSlot
Module zope.tal.talinterpreter, line 346, in interpret
Module zope.tal.talinterpreter, line 536, in do_optTag_tal
Module zope.tal.talinterpreter, line 521, in do_optTag
Module zope.tal.talinterpreter, line 516, in no_tag
Module zope.tal.talinterpreter, line 346, in interpret
Module zope.tal.talinterpreter, line 957, in do_defineSlot
Module zope.tal.talinterpreter, line 346, in interpret
Module zope.tal.talinterpreter, line 536, in do_optTag_tal
Module zope.tal.talinterpreter, line 521, in do_optTag
Module zope.tal.talinterpreter, line 516, in no_tag
Module zope.tal.talinterpreter, line 346, in interpret
Module zope.tal.talinterpreter, line 861, in do_defineMacro
Module zope.tal.talinterpreter, line 346, in interpret
Module zope.tal.talinterpreter, line 957, in do_defineSlot
Module zope.tal.talinterpreter, line 346, in interpret
Module zope.tal.talinterpreter, line 536, in do_optTag_tal
Module zope.tal.talinterpreter, line 521, in do_optTag
Module zope.tal.talinterpreter, line 516, in no_tag
Module zope.tal.talinterpreter, line 346, in interpret
Module zope.tal.talinterpreter, line 534, in do_optTag_tal
Module zope.tal.talinterpreter, line 516, in no_tag
Module zope.tal.talinterpreter, line 346, in interpret
Module zope.tal.talinterpreter, line 949, in do_defineSlot
Module zope.tal.talinterpreter, line 346, in interpret
Module zope.tal.talinterpreter, line 861, in do_defineMacro
Module zope.tal.talinterpreter, line 346, in interpret
Module zope.tal.talinterpreter, line 536, in do_optTag_tal
Module zope.tal.talinterpreter, line 521, in do_optTag
Module zope.tal.talinterpreter, line 516, in no_tag
Module zope.tal.talinterpreter, line 346, in interpret
Module zope.tal.talinterpreter, line 870, in do_useMacro
Module zope.tales.tales, line 696, in evaluate
URL: file:/home/ploneuser/Plone/cynapse/src/ubify.cyninv2theme/ubify/cyninv2theme/skins/ubify_cyninv2theme_custom_templates/app_images.pt
Line 64, Column 8
Expression: <PathExpr standard:u'context/atct_album_view/macros/main'>
Names:
{'container': <PloneSite at /cynin>,
'context': <ContentRoot at /cynin/root>,
'default': <object object at 0xb7c67528>,
'here': <ContentRoot at /cynin/root>,
'loop': {},
'nothing': None,
'options': {'args': ()},
'repeat': <Products.PageTemplates.Expressions.SafeMapping object at 0x12d0218c>,
'request': <HTTPRequest, URL=http://ip-address/cynin/root/app_images>,
'root': <Application at >,
'template': <FSPageTemplate at /cynin/app_images used for /cynin/root>,
'traverse_subpath': [],
'user': <PropertiedUser 'admin'>}
Module zope.tales.expressions, line 217, in __call__
Module Products.PageTemplates.Expressions, line 153, in _eval
Module zope.tales.expressions, line 124, in _eval
Module Products.PageTemplates.Expressions, line 83, in boboAwareZopeTraverse
Module zope.traversing.adapters, line 164, in traversePathElement
__traceback_info__: ({}, 'main')
Module zope.traversing.adapters, line 52, in traverse
__traceback_info__: ({}, 'main', [])
TraversalError: ({}, 'main')



Any Thoughts will be greatly appreciated.


Thanks,
Reigner Yrastorza
Replies (6)
migrationuser Oct 14, 2009 03:19 PM
Hi Reigner,

Hmmm.... this is a new one, never saw the app_images screen do that before.

Questions:
Have you modified anything in that template?

Are you on the community edition appliance or did you build the buildout from source snapshot?

Did this always happen when you clicked the images tab or did it start happening recently?

Is this happening on only the site root or in any new Space that you create, also?

Thanks for trying out cyn.in,
Regards,
Dhiraj Gupta.
migrationuser Oct 14, 2009 03:19 PM
Hi Dhiraj,

Thanks for the quick reply, to answer your questions -

Questions:
Have you modified anything in that template?

We’ve not modified anything to the template. Can we create a new one?

Are you on the community edition appliance or did you build the buildout from source snapshot?

We built it from the source snapshot, 3.2.1r4.

Did this always happen when you clicked the images tab or did it start happening recently?

I can’t be sure. It was only after I started cleaning up test images and test accounts that I tried clicking the root space menus and noticed this.

Is this happening on only the site root or in any new Space that you create, also?

It happens on new spaces created too.


Thanks,
Reigner Yrastorza
migrationuser Oct 14, 2009 03:19 PM
Hi Reigner,

Looking at your error trace, it's basically saying that the atct_album_view template does not have a macro named main.

So somehow either the whole file is missing, or somehow the main macro line has gotten changed in the file.

OR you installed the ploneslimbox product (or some other similar product which overrides the atct_album_view template but doesn't have the macro named main) from the quickinstaller screen in ZMI or the "Add-on products" screen in the cyn.in control panel. The ploneslimbox product is no longer in use, in cyn.in 2.1 and is there only for historical reasons (and the fact that we need to be able to migrate existing sites that have it with the new codebase).

If it's ploneslimbox, uninstall the product and things should work fine from that point on.
If it's some other product that you're trying to get to work on the images screen, then you're going to have figure out the main macro and put it there.

If it's neither of the above, try replacing the atct_album_view.pt template from the source snapshot zip. You'll find the file in your current checkout in : /home/ploneuser/Plone/cynapse/src/ubify.cyninv2theme/ubify/cyninv2theme/skins/ubify_cyninv2theme_custom_templates/atct_album_view.pt

In the zip file, it'll be at:
/src/ubify.cyninv2theme/ubify/cyninv2theme/skins/ubify_cyninv2theme_custom_templates/atct_album_view.pt

Do let us know how it went. I've a hunch that's it's the ploneslimbox product, but it could be something else as well.

Regards,
Dhiraj Gupta.
migrationuser Oct 14, 2009 03:19 PM
Thank you Dhiraj.
We appreciate your help.


Thanks,
Reigner Yrastorza
migrationuser Oct 14, 2009 03:20 PM

[Avatar]
2009-04-29 15:15:38 UTC
Always welcome. :)

So it worked out? The problem was plone slimbox only?

Regards,
Dhiraj Gupta
migrationuser Oct 14, 2009 03:20 PM
Hi Dhiraj,

Thanks that worked. We had uninstalled ploneslimbox and it worked.


Thanks,
Reigner Yrastorza
 
Loading