Please login or register to participate.
Discussion
.
dhiraj Nov 11, 2009 12:07 AM
Cyn.in 3.0.5 Release activity discussion
This discussion tracks the release activity being done for Cyn.in 3.0.5. Subscribe to this thread by Email / RSS for getting instant notifications when there's more updated info available.

The Cyn.in v3.0.5 ISO CD for is now available for download. This is the 5th iteration of the CD, it will be the final one for this release, if all goes well. Please test and report any issues or problems.

Download URL: http://odn.cynapse.com/[…]/cynincommunity-305-5-i386.iso.zip

This is for people who want to test with the new version on a new system. For updates to an existing installation, the debian packages have been built and automatic upgrades are being tested with them. They will be uploaded to the updates repository shortly. So you should hold on for the updates availability announcement in this discussion.

New documentation, announcements will also be first updated in this discussion. Stay tuned.
Replies (22)
huy0007 Nov 11, 2009 01:06 AM
Would you point me to the release notes of 3.0.5? I found 3.0.4 still has many issues during the whole installation and setup process. I found issues with compiling python-ldap-2.3.10 which is required by cynin 3.x and many other issues such as jpeg decoder error, etc... We finally managed to get 3.0.4 to work but still I still see many issues with 3.0.4, hopefully 3.0.5 fixes some of these issues. I was able to setup AD to work with 3.0.4 which is great and is the main reason for us to consider upgrading to 3.x.

1) Password change does work (reset work) but the password change from the admin page keeps saying 'ERROR current password is not correct' or something in to that affect.
2) I tried to export some simple contents (some empty spaces from cynin 2.x) and import into 3.0.4, it doesn't do anything.

Couple of other questions.

1) What the best way to upgrade from 3.0.4 to 3.0.5 without doing a lot of rework?
2) What the best way to migrate contents from Cyn.in 2.1 to 3.0.5?
dhiraj Nov 11, 2009 01:38 AM
You're trying to roll a production Cyn.in buildout and maintain it yourself? Try installing from the Installer CD, this installs with all the required packages on Debian 5. And you can maintain simply from that point on, because the CD actually installs through buildout only and then you can simply take it up as a development or production environment as you need. All required tools are already present and we also pre-setup a community apt-get update repository, which pushes updates out when they become available. Highly recommended, unless you're actually changing something in the buildout which breaks the normal update path through this channel.

For absolute guaranteed forward upgrade path, I'd recommend you sign up for an OnPremise appliance, that way Cynapse will handle any problems/issues that you otherwise sometimes might face with the forward migration in the Cyn.in CE CD, this is not always as thoroughly tested, but on the flip-side does usually have the latest features. :)

Like for example if you setup from the Cyn.in 3.0.4 CD and we release 3.0.5 pretty much all you'd have to do is press a few buttons for backing up, and upgrading would be automatic.

Anyways, for manual migration to new system from 2.x series all you have to do is copy the Data.fs file over to the new instance manually and *re-install* the ubify.sitepolicy product. This will automatically take care of all migration for you.

We maintain a full, automated migration path from all prior verions for Cyn.in. So unless you're customizing your buildout by adding unsupported products / changes, this is usually the best option if you're looking for maintainability.

The buildout way for Cyn.in has changed a bit drastically in 3.x, we're now using a virtualenv to get the proper python2.4 dependencies, and it's working much better from what I see/hear. The major reason for forcing this was that Ubuntu latest releases have dropped support for most python2.4 dependencies and python-imaging2.4 is now pretty much impossible to install on it from apt-get update.

What distro are you using? Please consult the quick-start buildout guide if you haven't already: http://www.cynapse.com/[…]/quickstart-buildout

Regarding password change..... I'm not sure I understand. You want to change passwords of your AD users administratively from within Cyn.in? The normal way to do this would be through your AD management interfaces, right? Or are you asking for a way to disable the password changing by users? This is not necessary if you set up AD as read-only. Please give us some more details on what this problem is, exactly. I'd prefer if you'd open a separate discussion topic for the password related discussion, we're trying to concentrate on the release activity thread, here.

The release notes for 3.0.5 are still being written, the CD was released just an hour or so ago. This discussion thread is for tracking activity on the release, which is still happening. It will be updated when any notes are available.

If you absolutely need to know immediately, you'll have to resort to consulting the closed issues list on ODN.
huy0007 Nov 12, 2009 12:50 AM
Thank you for the quick and detail response. We are introducing cynin to small IT group. Once we have the adoption, we'll probably consider the OnPremise appliance. I am very impressed with how quickly you respond to the questions posted by the community. Kudos to you!

We are rolling this out to development first and try to integrate with AD hopefully to roll this out to a bigger internal audience. We are trying to build this from the source on RedHat. We followed the quick start steps and use virtualenv.

For the password change, I tried to change the default password for siteadmin locally (not through AD) and it kept saying 'ERROR incorrect current password.' I don't remember the exact message but for some reasons, it didn't see the current password that I typed as the correct password (I was very careful to make sure I didn't have a typo by typing the password slowly one character at a time). I then went to user management link and force a password reset for 'siteadmin' to change the password that way.

For the content migration, I'll try copying the Data.fs file and reinstall ubify.sitepolicy (I didn't do this step and got a lot of errors.) Thanks.
dhiraj Nov 12, 2009 01:02 AM
Hmm...?
siteadmin login was not working? There's definitely a first time for everything! :)
The other login you can try in this situation is the "admin" username whose password is the same as siteadmin. Do note that the admin user is the "instance" admin user and exists "outside" the Cyn.in site itself - the main purpose of this user is to do ZMI management of the Zope server itself for tasks like packing of the server database files, etc.

I'll wait until someone else can reproduce this before I add it as an issue, myself. I really doubt there was an issue with the AD install that was causing this, both the logins and "normal" plone logins work in parallel, they will not interfere with each other unless there's a username collision. In case of collisions the winner will be determined by the priorities assigned to the different acl_plugins in each method of the pluggable authentication system (PAS).

So unless you also had a user in your AD with their sAMAccountName set to "siteadmin", I doubt AD itself was the culprit.
dhiraj Nov 11, 2009 01:39 AM
The ODN Issue list we maintain for tracking issue closure (by version) is at: http://odn.cynapse.com/projects/cynin/issues?query_id=13
dhiraj Nov 11, 2009 02:05 AM
Screenshots of anonymous setup have been uploaded, this is going to be a massive walkthrough! :)

Try this link: http://www.cynapse.com/comm[…]se&limit_display:int=50
dhiraj Nov 11, 2009 02:09 AM
Oops, this URL lists them in ascending order. The screenshots are full-size, so go for the Full-Size view when you need to see detail:
http://www.cynapse.com/comm[…]sc&limit_display:int=50

Will work on the setup guide that will explain all of this, once I put down the key highlights of the release in a blog post.
romasha Nov 11, 2009 05:15 PM
3.0.5 is now available! Release details, features and fixes are covered in this blog post here: http://www.cynapse.com/[…]/release-cyn.in-3.0.5-is-now-available
rstewart Nov 12, 2009 04:28 AM
The 3.0.5 ISO CD is not working for me. I burn the .iso to a CD just like I did with the 3.0.4 version, but on reboot it is not recognized as a bootable CD.

The CDROM drive is set to be the first boot item, and when I stick the 3.0.4 version in it boots from CD just fine.
dhiraj Nov 12, 2009 08:19 AM
Is this iteration 5 or 10 of the 3.0.5 CD that you're using? Both should run fine really. Especially if the ISO file extracts from the zip without a problem. That ISO was tested with VirtualBox before being uploaded. I *will* get someone to put a live test computer through with it, but I doubt the problem lies there.
dhiraj Nov 12, 2009 08:24 AM
If it *doesn't* extract from the zip file ok (WinZip, Winrar, 7z or whatever other program you're using will report a CRC checksum failure or something like that), then you've just had a download corruption, download it again.

Another thing you can do to diagnose the problem: Pop the CD in into an already running computer and see if the contents are showing up fine - does it look the same as the 3.0.4 CD structure? If not then you might have made a mistake in parameters while burning the ISO and you should burn it again. What software are you using to burn the CD?
dhiraj Nov 12, 2009 10:28 AM
The CD is booting fine, Richard, I just tested it myself. Please try writing it again and updating if it fixes the problem.
dhiraj Nov 12, 2009 10:45 AM
You can now run an upgrade as well, the debs are finally posted to the repo.
rstewart Nov 12, 2009 04:12 PM
PROBLEM FIXED
I didn't do anything particularly special when I burned the 3.0.4 ISO to CD from my Mac (OS 10.4), and it worked fine, but the 3.0.5 ISO wouldn't take.

I burned the 3.0.5 ISO using the Disk Utility application (found the instructions online) and it worked this time. Don't know if I was lucky the first time or what, but now I know the proper way to burn an ISO on a Mac.

Thanks again for all your help.
dhiraj Nov 12, 2009 10:45 AM
The upgrades have now been posted to the apt-get repository, and have been tested. All you folks with existing 3.0.4 can now follow the upgrade guide to upgrade your systems to the latest, here: http://www.cynapse.com/[…]/upgrade-cyn-in-3-x-community-appliance
dhiraj Nov 12, 2009 11:36 AM
The source code snapshot is up for download.

This time there's an updated README should prevent all the #fail messages that came up on twitter, the instructions in the Readme file in the SVN checkout were a leftover from the pre-3.0.4 days. We're now showing how to do the virtualenv based buildout in plain text in the readme.txt file.
Link: http://odn.cynapse.com/attachments/download/89/cynin305.zip
The SVN checkout URL for this is: http://odn.cynapse.com/svn/cynin/tags/cynin_3_0_5
pccynin Nov 30, 2009 01:44 AM
Hello dhiraj,
great product :-))
I have install cynin 3.0.4 over buildout.
I want to upgrade to 3.0.5. Thats all.
For me it is no good way to have a cd, because I install it in a datacenter.

I downloaded the cyin05.zip und unziped in a location.
Then normal buildout procedure.
And then: What I have to do? Only moviging the data.fs

Thank you in advance for your respond.
Regards
dhiraj Nov 30, 2009 09:38 AM
Yes, that is all that you have to do, *copy* over the Data.fs from your 3.0.4 buildout into your new 3.0.5 one. Then start it up and re-install the ubify.policy product. Remember to have a copy of your 3.0.4 one in case there are any issues.
pccynin Dec 01, 2009 12:56 AM
Dear Dhiraj,
I solved it with some complications because I installed extreme management as a product for testing. http://plone.org/[…]/155
Upgrading will only be successful without installing other products.
I droped the other products and then everything was fine.
That is only to inform you.
REALY GREAT PRODUCT !!!
 
dhiraj Dec 13, 2009 01:07 PM
Thanks! :)

Hmm... when you say "dropped" what did you do, exactly? If you just removed the extreme management product from your buildout or products folder then you should be aware that you might have some old objects left over in your installation's Data file - these "should" be removed manually, you'll have to hunt them down, though. This is usually not a big deal really, just causes some warnings, etc. to appear especially when you're installing/reinstalling products like the standard "xyz product has an incorrect setup handler" etc.

This situation can sometimes be avoided by first uninstalling the products from the portal_quickinstaller screen - do note that not all products (Cyn.in is one of these) support uninstallation.
 
Loading