Please login or register to participate.
Discussion
.
gogobd Feb 10, 2011 11:29 AM
I'm desperately trying to find documentation on how to disable the autosave feature. All I can find on this site are postings that refer to an article that is simply not there any more. Please (re-) post instructions on how to disable the autosave feature.
Replies (6)
gogobd Feb 10, 2011 04:42 PM
Well, I found another approach: I'm gonna use TinyMCE and see if the problems are gone then.
gogobd Feb 11, 2011 08:23 AM
But still: it would be good to know how to disable autosave.
dhiraj Feb 16, 2011 08:53 AM
There's no UI setting for this. To disable the Autosave permanently for all users, you'd have to comment out the Kinetic Style Sheets timer based save functionality that we added. This was added a long time ago, I'm not sure I remember where exactly this is, will have to look it up to be sure. I think it might be in jquery.cynincustom.js in ubify.viewlets. *Or* it might be separately present in a .kss file. One way to search for it is to run a grep on it in src folder with the id or class selector of the Save button in the Kupu editor.

Please ping again if you can't find it, will look it up.
gogobd Feb 21, 2011 12:28 PM
I have enabled logging / development mode for kss and found that "kupu.saveDataToField" was not defined - since it is added to the Kupu prototype in kupueditor.js I disabled merging for that script and now I keep my fingers crossed... Thank you for your hint!
timeu Feb 23, 2011 10:41 AM
@gogobd: Can you maybe elaborate a little bit more on how you succeeded in deactivating the autosave function? thanks in advance
gogobd Mar 31, 2011 07:14 AM
@timeu: actually I didn't. The autosave function is still in charge - I currently have no idea on how to get rid of it...
 
Loading