Please login or register to participate.
.
 
+

migrationuser I have tried siteadmin/secret and default usrname/pwd combo admin/password (in the README). These do not work.

Does anybody have a resolution to this error?

Thanks,
-Vijay


On Mon, Aug 25, 2008 at 3:44 PM, Vijay V <
vijaykv17@users.sourceforge.net> wrote:


Message body follows:

Hi,

I have installed the package, however I am unable to use the
admin/password combination when I enter it at the Server
Management console page. Could you please help on this?

Also, the package says "Linux", is the open source version
Linux only?

-Vijay

Rating
0
Last workflowed by viraf
Nov 10, 2009 11:30 AM
+

migrationuser I get here an exception and doesn't know even to start:

2009-01-26 00:51:18 INFO GenericSetup.ubify.policy Site title has already been changed, so NOT changing site title or description.

2009-01-26 00:51:18 ERROR Zope.SiteErrorLog
http://localhost:8080/[…]/addPloneSite
Traceback (innermost last):
Module ZPublisher.Publish, line 119, in publish
Module ZPublisher.mapply, line 88, in mapply
Module ZPublisher.Publish, line 42, in call_object
Module Products.CMFPlone.factory, line 87, in addPloneSite
Module Products.GenericSetup.tool, line 390, in runAllImportStepsFromProfile
- __traceback_info__: profile-ubify.policy:default
Module Products.GenericSetup.tool, line 1182, in _runImportStepsFromContext
Module Products.GenericSetup.tool, line 1093, in _doRunImportStep
- __traceback_info__: ubify-various
Module ubify.policy.setuphandlers, line 760, in importVarious
Module ubify.policy.setuphandlers, line 90, in configureContentTypes
Module ubify.policy.setuphandlers, line 77, in renameScrawl
AttributeError: Blog Entry
Unhandled exception in thread started by <class ZServer.PubCore.ZServerPublisher.ZServerPublisher at 0xb738953c>
Traceback (most recent call last):
File "/home/drnetwork/cyn.in/parts/zope2/lib/python/ZServer/PubCore/ZServerPublisher.py", line 25, in __init__
response=b)
File "/home/drnetwork/cyn.in/parts/zope2/lib/python/ZPublisher/Publish.py", line 401, in publish_module
environ, debug, request, response)
File "/home/drnetwork/cyn.in/parts/zope2/lib/python/ZPublisher/Publish.py", line 227, in publish_module_standard
if request is not None: request.close()
File "/home/drnetwork/cyn.in/parts/zope2/lib/python/ZPublisher/HTTPRequest.py", line 151, in close
BaseRequest.close(self)
File "/home/drnetwork/cyn.in/parts/zope2/lib/python/ZPublisher/BaseRequest.py", line 208, in close
notify(EndRequestEvent(None, self))
File "/home/drnetwork/cyn.in/parts/zope2/lib/python/zope/event/__init__.py", line 23, in notify
subscriber(event)
File "/home/drnetwork/cyn.in/parts/zope2/lib/python/zope/component/event.py", line 26, in dispatch
for ignored in zope.component.subscribers(event, None):
File "/home/drnetwork/cyn.in/parts/zope2/lib/python/zope/component/_api.py", line 130, in subscribers
return sitemanager.subscribers(objects, interface)
File "/home/drnetwork/cyn.in/parts/zope2/lib/python/zope/component/registry.py", line 290, in subscribers
return self.adapters.subscribers(objects, provided)
AttributeError: adapters

- ubuntu server edition
- cyn2_1_source_snapshot
installed like in readme only lxml by "sudo apt-get python-lxml"

Rating
0
Last workflowed by viraf
Nov 10, 2009 11:30 AM
+

migrationuser I get an error when trying to start the Zope instance

kunj@kunj-desktop:~/Desktop/cyn2_1$ ./bin/instance fg
/home/kunj/Desktop/cyn2_1/parts/instance/bin/runzope -X debug-mode=on
2009-01-28 13:35:42 INFO ZServer HTTP server started at Wed Jan 28 13:35:42 2009
Hostname: 0.0.0.0
Port: 8080
2009-01-28 13:35:43 ERROR PortalTransforms Problem importing module image_to_png : No module named PIL.Image
2009-01-28 13:35:43 ERROR PortalTransforms Problem importing module image_to_gif : No module named PIL.Image
2009-01-28 13:35:43 ERROR PortalTransforms Problem importing module image_to_jpeg : No module named PIL.Image
2009-01-28 13:35:43 ERROR PortalTransforms Problem importing module image_to_pcx : No module named PIL.Image
2009-01-28 13:35:43 ERROR PortalTransforms Problem importing module image_to_ppm : No module named PIL.Image
2009-01-28 13:35:43 ERROR PortalTransforms Problem importing module image_to_tiff : No module named PIL.Image
2009-01-28 13:35:43 ERROR PortalTransforms Problem importing module image_to_bmp : No module named PIL.Image
2009-01-28 13:35:44 INFO Archetypes /home/kunj/Desktop/cyn2_1/parts/plone/Archetypes/Field.py[102]:?
Warning: no Python Imaging Libraries (PIL) found.Archetypes based ImageField's don't scale if neccessary.

2009-01-28 13:35:44 ERROR Application Could not import Products.ATContentTypes
Traceback (most recent call last):
File "/home/kunj/Desktop/cyn2_1/parts/zope2/lib/python/OFS/Application.py", line 709, in import_product
product=__import__(pname, global_dict, global_dict, silly)
File "/home/kunj/Desktop/cyn2_1/parts/plone/ATContentTypes/__init__.py", line 64, in ?
import Products.ATContentTypes.content
File "/home/kunj/Desktop/cyn2_1/parts/plone/ATContentTypes/content/__init__.py", line 26, in ?
import Products.ATContentTypes.content.link
File "/home/kunj/Desktop/cyn2_1/parts/plone/ATContentTypes/content/link.py", line 39, in ?
from Products.ATContentTypes.content.base import registerATCT
File "/home/kunj/Desktop/cyn2_1/parts/plone/ATContentTypes/content/base.py", line 63, in ?
from Products.CMFPlone.PloneFolder import ReplaceableWrapper
File "/home/kunj/Desktop/cyn2_1/parts/plone/CMFPlone/__init__.py", line 215, in ?
from browser import ploneview
File "/home/kunj/Desktop/cyn2_1/parts/plone/CMFPlone/browser/ploneview.py", line 12, in ?
from Products.CMFPlone import utils
File "/home/kunj/Desktop/cyn2_1/parts/plone/CMFPlone/utils.py", line 6, in ?
from PIL import Image
ImportError: No module named PIL
Traceback (most recent call last):
File "/home/kunj/Desktop/cyn2_1/parts/zope2/lib/python/Zope2/Startup/run.py", line 56, in ?
run()
File "/home/kunj/Desktop/cyn2_1/parts/zope2/lib/python/Zope2/Startup/run.py", line 21, in run
starter.prepare()
File "/home/kunj/Desktop/cyn2_1/parts/zope2/lib/python/Zope2/Startup/__init__.py", line 102, in prepare
self.startZope()
File "/home/kunj/Desktop/cyn2_1/parts/zope2/lib/python/Zope2/Startup/__init__.py", line 278, in startZope
Zope2.startup()
File "/home/kunj/Desktop/cyn2_1/parts/zope2/lib/python/Zope2/__init__.py", line 47, in startup
_startup()
File "/home/kunj/Desktop/cyn2_1/parts/zope2/lib/python/Zope2/App/startup.py", line 45, in startup
OFS.Application.import_products()
File "/home/kunj/Desktop/cyn2_1/parts/zope2/lib/python/OFS/Application.py", line 686, in import_products
import_product(product_dir, product_name, raise_exc=debug_mode)
File "/home/kunj/Desktop/cyn2_1/parts/zope2/lib/python/OFS/Application.py", line 709, in import_product
product=__import__(pname, global_dict, global_dict, silly)
File "/home/kunj/Desktop/cyn2_1/parts/plone/ATContentTypes/__init__.py", line 64, in ?
import Products.ATContentTypes.content
File "/home/kunj/Desktop/cyn2_1/parts/plone/ATContentTypes/content/__init__.py", line 26, in ?
import Products.ATContentTypes.content.link
File "/home/kunj/Desktop/cyn2_1/parts/plone/ATContentTypes/content/link.py", line 39, in ?
from Products.ATContentTypes.content.base import registerATCT
File "/home/kunj/Desktop/cyn2_1/parts/plone/ATContentTypes/content/base.py", line 63, in ?
from Products.CMFPlone.PloneFolder import ReplaceableWrapper
File "/home/kunj/Desktop/cyn2_1/parts/plone/CMFPlone/__init__.py", line 215, in ?
from browser import ploneview
File "/home/kunj/Desktop/cyn2_1/parts/plone/CMFPlone/browser/ploneview.py", line 12, in ?
from Products.CMFPlone import utils
File "/home/kunj/Desktop/cyn2_1/parts/plone/CMFPlone/utils.py", line 6, in ?
from PIL import Image
ImportError: No module named PIL

What i understand from above error is that PIL (Python Imaging Library) is not installed in the machine.
When i try to install python-imaging package

apt-get install python-imaging

It says packages is already installed.

- ubuntu desktop edition
- cyn2_1_source_snapshot

Rating
0
Last workflowed by viraf
Nov 10, 2009 11:30 AM
+

migrationuser I get an error when starting the newly created site:

This is the site error:
>>>
Site Error

An error was encountered while publishing this resource.

KeyError

Sorry, a site error occurred.
Traceback (innermost last):

Module ZPublisher.Publish, line 202, in publish_module_standard
Module ZPublisher.Publish, line 150, in publish
Module plone.app.linkintegrity.monkey, line 21, in zpublisher_exception_hook_wrapper
Module Zope2.App.startup, line 221, in zpublisher_exception_hook
Module ZPublisher.Publish, line 119, in publish
Module ZPublisher.mapply, line 88, in mapply
Module ZPublisher.Publish, line 42, in call_object
Module Products.Five.browser.metaconfigure, line 417, in __call__
Module Shared.DC.Scripts.Bindings, line 313, in __call__
Module Shared.DC.Scripts.Bindings, line 350, in _bindAndExec
Module Products.PageTemplates.PageTemplateFile, line 129, in _exec
Module Products.CacheSetup.patch_cmf, line 74, in PT_pt_render
Module Products.CacheSetup.patch_utils, line 9, in call_pattern
Module Products.PageTemplates.PageTemplate, line 89, in pt_render
Module zope.pagetemplate.pagetemplate, line 117, in pt_render
Module zope.tal.talinterpreter, line 271, in __call__
Module zope.tal.talinterpreter, line 346, in interpret
Module zope.tal.talinterpreter, line 891, in do_useMacro
Module zope.tal.talinterpreter, line 346, in interpret
Module zope.tal.talinterpreter, line 536, in do_optTag_tal
Module zope.tal.talinterpreter, line 521, in do_optTag
Module zope.tal.talinterpreter, line 516, in no_tag
Module zope.tal.talinterpreter, line 346, in interpret
Module zope.tal.talinterpreter, line 957, in do_defineSlot
Module zope.tal.talinterpreter, line 346, in interpret
Module zope.tal.talinterpreter, line 536, in do_optTag_tal
Module zope.tal.talinterpreter, line 521, in do_optTag
Module zope.tal.talinterpreter, line 516, in no_tag
Module zope.tal.talinterpreter, line 346, in interpret
Module zope.tal.talinterpreter, line 854, in do_condition
Module Products.PageTemplates.Expressions, line 211, in evaluateBoolean
Module zope.tales.tales, line 696, in evaluate
URL: file:/cyn/src/ubify.cyninv2theme/ubify/cyninv2theme/skins/ubify_cyninv2theme_custom_templates/main_template.pt
Line 115, Column 20
Expression: <StringExpr u'ubify.allspacesmenumanager'>
Names:
{'container': <PloneSite at /cynin>,
'context': <PloneSite at /cynin>,
'default': <object object at 0xb7d7f528>,
'here': <PloneSite at /cynin>,
'loop': {},
'nothing': None,
'options': {'args': (<Products.Five.metaclass.SimpleViewClass from /cyn/src/ubify.cyninv2theme/ubify/cyninv2theme/browser/sitehome.pt object at 0xd40e7ec>,)},
'repeat': <Products.PageTemplates.Expressions.SafeMapping object at 0xd40cc6c>,
'request': <HTTPRequest, URL=
http://10.10.100.107:8080/cynin/site_home>,
'root': <Application at >,
'template': <ImplicitAcquirerWrapper object at 0xd4112ac>,
'traverse_subpath': [],
'user': <PloneUser 'siteadmin'>,
'view': <Products.Five.metaclass.SimpleViewClass from /cyn/src/ubify.cyninv2theme/ubify/cyninv2theme/browser/sitehome.pt object at 0xd40e7ec>,
'views': <zope.app.pagetemplate.viewpagetemplatefile.ViewMapper object at 0xcf2d28c>}
Module Products.Five.browser.providerexpression, line 34, in __call__
Module zope.viewlet.manager, line 104, in update
Module ubify.viewlets.browser.allspacesviewlet, line 112, in update
Module ubify.viewlets.browser.allspacesviewlet, line 88, in getAddMenuItems
KeyError: 'id' (Also, the following error occurred while attempting to render the standard error message, please see the event log for full details: 'id')
Troubleshooting Suggestions

The URL may be incorrect.
The parameters passed to this resource may be incorrect.
A resource that this resource relies on may be encountering an error.
For more detailed information about the error, please refer to the error log.

If the error persists please contact the site maintainer. Thank you for your patience.
>>>

In the fg screen:
>>>
File "/cyn/src/ubify.viewlets/ubify/viewlets/browser/allspacesviewlet.py", line 88, in getAddMenuItems
ob['portal_type'] = ob['id']
KeyError: 'id'

Rating
0
Last workflowed by viraf
Nov 10, 2009 11:30 AM
+

migrationuser I downloaded the 2.1 appliance and followed the readme.txt instructions. With the network adapter in bridged mode, I started the cyn.in appliance. It wants a login at https://192.168.177.128:8003. (Your suggested user names and passwords did not work.)

On my host machine, using Firefox, I tried to access http://192.168.177.128:8004 per your instructions, but there's no response. Have I missed something?

Dan

Rating
0
Last workflowed by viraf
Nov 10, 2009 11:30 AM
+

migrationuser Hi,

When I install the cyn.in v2.1, the following error is shown. Has any idea?


..........
Note also that the installation directory must be on sys.path at runtime for
this to work. (e.g. by being the application's script directory, by being on
PYTHONPATH, or by being added to sys.path by your code.)

Got elementtree 1.2.7-20070827-preview.
Picked: elementtree = 1.2.7-20070827-preview
Installing zope2.
While:
Installing zope2.

An internal error occured due to a bug in either zc.buildout or in a
recipe being used:
Traceback (most recent call last):
File "/tmp/tmpy20AjW/zc.buildout-1.1.1-py2.4.egg/zc/buildout/buildout.py", line 1477, in main
File "/tmp/tmpy20AjW/zc.buildout-1.1.1-py2.4.egg/zc/buildout/buildout.py", line 462, in install
File "/tmp/tmpy20AjW/zc.buildout-1.1.1-py2.4.egg/zc/buildout/buildout.py", line 1060, in _call
File "/root/cyn2_1/eggs/plone.recipe.zope2install-2.6-py2.4.egg/plone/recipe/zope2install/__init__.py", line 169, in install
setuptools.archive_util.unpack_archive(fname, tmp)
File "/root/cyn2_1/eggs/setuptools-0.6c9-py2.4.egg/setuptools/archive_util.py", line 67, in unpack_archive
File "/root/cyn2_1/eggs/setuptools-0.6c9-py2.4.egg/setuptools/archive_util.py", line 192, in unpack_tarfile
File "/usr/lib64/python2.4/tarfile.py", line 1423, in _extract_member
self.makefile(tarinfo, targetpath)
File "/usr/lib64/python2.4/tarfile.py", line 1461, in makefile
copyfileobj(source, target)
File "/usr/lib64/python2.4/tarfile.py", line 158, in copyfileobj
shutil.copyfileobj(src, dst)
File "/usr/lib64/python2.4/shutil.py", line 22, in copyfileobj
buf = fsrc.read(length)
File "/usr/lib64/python2.4/tarfile.py", line 558, in _readnormal
return self.__read(bytestoread)
File "/usr/lib64/python2.4/tarfile.py", line 504, in __read
return self.fileobj.read(size)
File "/usr/lib64/python2.4/gzip.py", line 225, in read
self._read(readsize)
File "/usr/lib64/python2.4/gzip.py", line 273, in _read
self._read_eof()
File "/usr/lib64/python2.4/gzip.py", line 309, in _read_eof
raise IOError, "CRC check failed"
IOError: CRC check failed
[root@dev-uat01 cyn2_1]#

Rating
0
Last workflowed by viraf
Nov 10, 2009 11:30 AM
+

migrationuser Hi,

When I install cynin 2.0.5, why the error message "Download error: (110, 'Connection timed out') -- Some packages may not be found!" is shown occasionally ?


............
............
Installed /root/cynin_v2_0_5/eggs/tmpVZGSsG/plone.recipe.zope2instance-2.8-py2.4.egg

Because this distribution was installed --multi-version, before you can
import modules from this package in an application, you will need to
'import pkg_resources' and then use a 'require()' call similar to one of
these examples, in order to select the desired version:

pkg_resources.require("plone.recipe.zope2instance") # latest installed version
pkg_resources.require("plone.recipe.zope2instance==2.8") # this exact version
pkg_resources.require("plone.recipe.zope2instance>=2.8") # this version or higher


Note also that the installation directory must be on sys.path at runtime for
this to work. (e.g. by being the application's script directory, by being on
PYTHONPATH, or by being added to sys.path by your code.)

Got plone.recipe.zope2instance 2.8.
Picked: plone.recipe.zope2instance = 2.8
Installing 'infrae.subversion'.
We have no distributions for infrae.subversion that satisfies 'infrae.subversion'.
Download error: (110, 'Connection timed out') -- Some packages may not be found!
Download error: (110, 'Connection timed out') -- Some packages may not be found!
Download error: (110, 'Connection timed out') -- Some packages may not be found!
Download error: (110, 'Connection timed out') -- Some packages may not be found!
Download error: (110, 'Connection timed out') -- Some packages may not be found!
Download error: (110, 'Connection timed out') -- Some packages may not be found!

Rating
0
Last workflowed by viraf
Nov 10, 2009 11:30 AM
 
Loading